RIP Config Example.

RIP.jpeg

I configuration the RIP protocol as per the above scenario.

Router1 configuration,

R1#show running-config
Building configuration…
Current configuration : 1883 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
interface Ethernet0/0
ip address 10.10.10.1 255.255.255.0
ip rip advertise 2
!
interface Serial2/0
ip address 172.16.1.1 255.255.255.252
ip rip advertise 2
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
router rip
version 2
no auto-summary
timers basic 2 8 8 12
network 10.10.10.0
network 172.16.1.0
!
ip forward-protocol nd
!
end

Router2 Configuration,

R2#show running-config
Building configuration…
Current configuration : 1884 bytes
!
Last configuration change at 10:25:38 UTC Sun Aug 13 2017
version 15.2
!
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
interface Ethernet1/3
no ip address
shutdown
!
interface Serial2/0
ip address 172.16.1.2 255.255.255.252
serial restart-delay 0
!
interface Serial2/1
ip address 172.17.1.1 255.255.255.252
serial restart-delay 0
!
router rip
version 2
no auto-summary
network 172.16.1.0
network 172.17.1.0
!
ip forward-protocol nd
!
End

Router3 Configuration,

R3#show running-config
Building configuration…
Current configuration : 1872 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
interface Ethernet0/0
ip address 10.20.20.1 255.255.255.0
ip rip advertise 2
!
interface Serial2/1
ip address 172.17.1.2 255.255.255.252
ip rip advertise 2
serial restart-delay 0
!
!
router rip
version 2
no auto-summary
timers basic 2 8 8 12
network 10.20.20.0
network 172.17.1.0
!
ip forward-protocol nd
!
End

You done the as per the above configuration, both PC’s are ping each other without any packet loss.

Advertisements

Routing Protocols

There are two types of Routing Protocols,

  • Static Routing
  • Dynamic Routing

Static Routing Protocols:-

In this configuration Routing table is managing by the Network Admin manually. A static route must be configured all routers on network to communicate each others. This Routing not suit for large network because of configuration all routers routes manually become headache. But this is reduce the CPU, RAM and bandwidth overhead.
The static routing is not a fault-tolerant because, any link or router down, the router will not redirect the route..ūüėą
Static Routing can be¬†config¬†with next hop¬†IP¬†address or outgoing interface. if we use out going interface the Administrative Distance or AD will be “0” or we use the next hop count¬†IP¬†address the AD will be “1”.
syntax: Router(config)#ip route 10.10.10.1 255.255.255.0 s0/0
or
Router(config)#ip route 10.10.10.1 255.255.255.0 192.168.1.2
10.10.10.1==> is destination IP
192.168.1.2==> next hop address
s0/0==> is the out going interface

Dynamic Routing protocols: 

in this configure Routers Routing table maintained by the Dynamic Routing protocols them-self. these are select the best route to the destination and also make load balance between links. And any link or router goes down the routing protocol will redirect or find the other route for the destination(if available). no need of Network admin to interfere to change the route. In this type the Router CPU, ROM and bandwidth of link consumption will be more.
Some example of the Dynamic Routing Protocols are RIP,¬†OSPF,¬†EIGRP¬†etc…

RIP (Routing Information Protocols)

Basic Notes:

*It’s a Distance Vector Protocol, so it send full routing table to it’s neighbors,
*RIP administrative distance is 120,
*RIP use the UDP 520,
*RIP use the “Bellaman-fard algoritham” to find the best path to destination,
*RIP use the hop count as a Matrics
*RIP max hop count is 15, above of it RIP consider as a unreachable,
*RIP send routing updates every 30sec
*RIP will be make load balancing b/w multiple paths (Max 4 paths),
*RIP default Auto-summary enabled,
*It useful for small office’s,

RIP Versions,

Version1==>It’s a classfull and it’s send the routing updates to broadcast address 255.255.255.255.
Version2==> it’s supports the classless IP address and it’s send the updates to multicast 224.0.0.9 address and also support hash MD5 authentication.

All Cisco Routers default have the RIP version1

Commands,

Router(Config)#Router rip
Router(Config-Router)#version 1 (for Version1)
Router(Config-Router)#version 2 (For Version2)

Syntax of RIP:

Router(Config)#Router rip
Router(Config-Router)#version 2
Router(Config-Router)#network 10.10.10.0
Router(Config-Router)#network 172.16.1.0
Router(Config-Router)#no auto-summary

RIP loop avoid mechanism :

  1. Split-Horizon:- Prevent the routing updates sent through the same interface it received. This mechanism default enabled in Cisco.
  2. Route- Poising:- This mechanism trigger the automatic update of failed network without waiting for the regular update timer expire. this type update sent to all interface with the infinity matrics.
  3. Hold-Down Timers:- It will prevent the RIP from accepting the any updates for router in hold-down state, until the hold-down timer expire.

Basic RIP Config watch here…

CISCO IP 7906G FIRMWARE UPDATION

  1. Download the latest from http://TFTPd32.jounin.net/TFTPd32_download.html
  2. Unzip the file.
  3. Double click on Tftpd32.exe in decompressed folder to start Tftpd32. The following figure is the main window after starting Tftpd32.1
  4. Click setting to open the following window, click to TFTP tab.2
  5. (a). Click Browse to select the directory that firmware image file existed. Then come back to GLOBAL tab.3

(b). Uncheck TFTP Client and Syslog Server.4a

(c). click OK to apply the new configuration.

  1. One message box recommends user to restart Tftpd32. Please restart Tftpd32.4
  2. After restart Tftpd32, click DHCP server to set up DHCP server5
  3. Change DHCP server configuration same as showing below figure then click OK.9. Now connect your IP phone to PC with Straight cable.6
  4. To precede firmware update is showing like this.7
  5. After 5 to 10 minutes, IP Phone display will came.
  6. Unlock the IP Phone to pressing **#. And disable the DHCP on configuration menu.
  7. Now you configure the IP phone with your previous IP address, subnet mask, and gateway and TFTP servers on IP phone.
Note: If Cisco IP Phone need any update file it will automatically download
from the Call Manager. 

Changing the MTU size in Windows PC

Hi guys, one day we need to check the bandwidth of the leased internet link provided by ISP. we continuously checked 4 days but is not reached required amount of bandwidth. then as per the ISP suggestion we changed the MTU size from default 1500 to 9200 bytes. after this changes we reach the maximum bandwidth with use of Solar wind Wan Killer.

Once the Command Prompt window is open follow the steps below to change the MTU size:

  1. Type netsh interface ipv4 show subinterface
  2. Press Enter.

MTU

  1. You will see a list of network interfaces.
  2. Type netsh interface ipv4 set subinterface ‚ÄúLocal Area Connection‚ÄĚ mtu=1458 store=persistent
    You should replace Local Area Connection with the name that appeared in the ‚ÄúInterface‚ÄĚ column¬†from steps 1-3.
  3. Press Enter.
  4. Restart you computer and then test again.

The PC is set the MTU size as per your request. now you can push the more amount of data to the network.

don't try to set in working environment, it will affect the internal network,

OSI Reference Model

The Open Systems Interconnection (OSI) model was developed by the International Organization for Standardization (ISO), and formalized in 1984. It provided the standardized framework  of Networking communication. The OSI model consists of seven layers, each corresponding to a specific network function:

basics_osimodel-56a1ad0c5f9b58b7d0c19c53

The OSI models are divide into 2 part One is Upper layers and Lower layers see the above Picture for same.

1. Application Layer

Application layer provides platform to send and receive data over the network. All applications and utilities that communicate with network will come in this layer.

For examples: All Browsers, TFTP, SNMP, FTP, Telnet, Mail clients, DNS and DHCP,

2. Presentation layer

The presentation layer formats the data to be presented to the application layer. It can be viewed as the translator for the network. This layer may translate data from a format used by the application layer into a common format at the sending station, then translate the common format to a format known to the application layer at the receiving station.

This layer can also encapsulate the data, but it’s uncommon as this can be done by lower layers more effectively.

3. The Session Layer

Session layer deals with connections. It establishes, manages, and terminates sessions between two communicating nodes. This layer provides its services to the presentation layer. Session layer also synchronizes dialogue between the presentation layers of the two hosts and manages their data exchange. For example, web servers may have many users communicating with server at a given time. Therefore, keeping track of which user communicates on which path is important and session layer handle this responsibility accurately.

4. Transport Layer

The transport layer ensures that messages are delivered error-free, in sequence, and with no losses or duplication. It relieves the higher layer protocols from any concern with the transfer of data between them and their peers.

The size and complexity of a transport protocol depends on the type of service it can get from the network layer. For a reliable network layer with virtual circuit capability, a minimal transport layer is required. If the network layer is unreliable and/or only supports datagrams, the transport protocol should include extensive error detection and recovery.

The transport layer provides:

  • Message segmentation: accepts a message from the (session) layer above it, splits the message into smaller units (if not already small enough), and passes the smaller units down to the network layer. The transport layer at the destination station reassembles the message.
  • Message acknowledgment: provides reliable end-to-end message delivery with acknowledgments.
  • Message traffic control: tells the transmitting station to “back-off” when no message buffers are available.
  • Session multiplexing: multiplexes several message streams, or sessions onto one logical link and keeps track of which messages belong to which sessions

Typically, the transport layer can accept relatively large messages, but there are strict message size limits imposed by the network (or lower) layer. Consequently, the transport layer must break up the messages into smaller units, or frames, prepending a header to each frame.

In addition, if the lower layers do not maintain sequence, the transport header must contain sequence information to enable the transport layer on the receiving end to get the pieces back together in the right order before handing the received message up to the layer above.

5. Network Layer

The network layer controls the operation of the subnet, deciding which physical path the data should take based on network conditions, priority of service, and other factors. It provides:

  • Routing: routes frames among networks.
  • Subnet traffic control: routers (network layer intermediate systems) can instruct a sending station to “throttle back” its frame transmission when the router’s buffer fills up.
  • Frame fragmentation: if it determines that a downstream router’s maximum transmission unit (MTU) size is less than the frame size, a router can fragment a frame for transmission and re-assembly at the destination station.
  • Logical-physical address mapping: translates logical addresses, or names, into physical addresses.
  • Subnet usage accounting: has accounting functions to keep track of frames forwarded by subnet intermediate systems, to produce billing information.

6. Data link layer

The data link layer provides error-free transfer of data frames from one node to another over the physical layer, allowing layers above it to assume virtually error-free transmission over the link. To do this, the data link layer provides:

  • Link establishment and termination: establishes and terminates the logical link between two nodes.
  • Frame traffic control: tells the transmitting node to “back-off” when no frame buffers are available.
  • Frame sequencing: transmits/receives frames sequentially.
  • Frame acknowledgment: provides/expects frame acknowledgments. Detects and recovers from errors that occur in the physical layer by retransmitting non-acknowledged frames and handling duplicate frame receipt.
  • Frame delimiting: creates and recognizes frame boundaries.
  • Frame error checking: checks received frames for integrity.
  • Media access management: determines when the node “has the right” to use the physical medium.

7. Physical Layer

Physical layer deals with communication media. This layer receive frame from data link layer and convert them in bits. It loads these bits on actual communication media. Depending on media type these bit values are converted in single. Physical medium transmission: transmits bits as electrical or optical signals appropriate for the physical medium, and determines.